Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Any way to get DSM 7.2 to use usb ethernet upgrade for internet connection?

Hi, all!

I just followed the great guide ("Synology 2.5GbE / 5GbE USB Adapter Setup Guide - DSM 7 Version") and added a 2.5g ethernet usb adapter to my aging Synology DS 218+ (running DSM 7.2). The Control Panel > Network > Network Interface gui shows both the original 1000Mbps and the new 2500Mbps LAN nics are connected and set to different static ips, with the same subnet mask, gateway, and DNS server.  The router/modem from the ISP, and both the 1Gbps and 2.5Gbpsethernet cables from the nas are running directly into a 2.5g unmanaged switch with cat 7 cables. With this setup I can access my docker services ports easily on either new or old nic ip.

Main Question:

One reason I decided to do the upgrade is because my new ISP has me on a promotional package with 1500Mbps download, and I thought I might as well try to max that out. But with when I run an interent speed test (with both nas ethernet ports still connected), I still get a result of ~1000Gbps, rather than ~1500. If I boot with both connected and then disconnect the 1Gbps ethernet, I can still access the docker service ports on the new ip, but don't seem to get any internet connection. Is there something else I need to do (if it's actually possible) to get the nas to use the new 2.5g ethernet for connecting to the internet rather than the old ~1000Gbps connection? I've found Control Panel > Network > Network Interface > Manage > Service Order, but as far as I can tell, changing the order doesn't change anything.

Secondary Question:
If there's a way to solve the main question, is there any way to use the original 1000Gbps ethernet connection as a backup in case the 2500Gbps usb connection fails?

Thank you so much for any help! I'm quite out of my depth on networking at this point haha Blush
Just posting to say I managed to figure it out. The problem: A faulty switch that was only working as 1gbps and not 2.5. Got it replaced and it's working fine now.

Forum Jump:

Users browsing this thread: 1 Guest(s)