Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TVS-h1288x with 8x WD Ultrastar 20Tb drives, poor / erratic performance (QTS, not QuTS)
#1
Hi. Great website! I'm just wondering if you might have some idea's on what could be going wrong with my TVS-h1288x.
I WAS running 8x WD Red Pro 6Tb drives, in Raid 6 in this unit. They were originally migrated from my TVS-872XT which failed a motherboard for a 2nd time, and I was fortunate enough to be allowed a credit on my now TVS-h1288x, but since my Red Pro drives were running on QTS, it was necessary to change my TVS-h1288x back to QTS before adding the drives to it, to allow it to recover the array, and subsequently the data on it (had no backup).

Anyway! I also still have my older TVS-663 that was also running 6Tb red (not pro, and not smr) drives, also in raid 6, but setup as a LUN over iscsi 10Gb ethernet to QSW-M1208-8c 10Gb switch to get back to the 1288x.

So, if you're with me, I was sacrificing 4 drives out of 14, and running out of space. So i found what for me was a pretty good deal on 8x WD Ultrastar 20Tb drives, and after running drive diagnostics over every sector of the new drives, did the 1 by 1 swap method of migrating the new drives in, and then expanding the storage pool, and volume to the maximum possible size, and as a thick volume. Everything went well, except that by the time i had 5 drives swapped in, i decided to test out the speed with Qnaps built in performance test, and discovered some very inconsistent drive speeds on the ultrastars, compared to the 3 remaining red pro drives. They've been testing anywhere from 120mb/s to 206mb/s i think is the highest i've seen. Where my red pro's would fairly consistently score 234-240mb/s. IOPS was also scoring only between 97 and 128 odd on the ultrastars where the red pro's would consistently score either 146 or 147.
I've tried running qcli_storage -T / -t and it was all over the place as well. It isn't crashing or anything, but it does feel like I can't really load it up without it slowing down, where before it seemed like it would just take everything i through at it and not really bother it.

I pulled one out and plugged it into a windows box, and benched it with crystaldisk and atto, and saw the speeds you'd expect from an Ultrastar drive. About 260mb/s read/write on crystaldisk, and atto sitting about 250mb/s on all tests from 16k and up, and dropping down to 44mb/s odd on 512b tests. Again what you'd expect.

I do not have any other drives present as yet. I plan on getting probably a pair of wd red m.2's, and possibly wd red 2.5" ssd's to fill it out later. I may even try Qtier at that point, but until I can get this resolved I don't want to be throwing more money at it.

I did add 64Gb of ecc udimms, and it's running fine alongside the original 16gb. I did try with just the 16gb, and with just the 64gb and run the tests again to see if it made any difference, but no joy there.
Only other addition is my P2000 which i use primarily for tdarr via container station.

Do you have any idea's on what could be causing the Ultrastars to run so poorly in my Qnap?

Also do you have any other ideas for testing them in the qnap?

I've tried to reach out to Qnap and so far it seems more like they want to blame the hard drive. I reached out to Western Digital also to ask if there might be perhaps some external driver for linux because of the optinand stuff etc, and they just said the drivers are all internal.

Really at a loss as to what could be going wrong...

Anyway, love your work on the website, and just hope your experience might give me a few idea's to check out.

Many thanks for reading all this!!

Cheers,
Dave.
Gold Coast, Australia.
Reply
#2
Yes, this is an unusual case. If tests on Windows come out just fine, you are right, there is something with driver/firmware. I would check the serial, maybe there is new firmware available on these drives. You would often see firmware versions mentioned on Synology compatibility lists. Qnap should have something similar.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)