Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Expanding my RAID?

Hi. I really need help on this one. I'm so stuck. I have a QNAP TVS 872XT with 4 X 4tb drives inside configured as RAID 10. As I'm starting to run out of space I decided to purchase another two 4tb drives to expand the array. I have powered down the NAS and installed the two new drives. Now that I have booted up, logged in and gone to storage/snapshot. Then to manage and clicked on expand, the option to expand is not available. I can see the drives listed as free. I'm not sure what is happening here, but I have the sneaking suspicion that I need to basically delete the volume and start a new array. Is this correct? I would have thought it was as simple as just adding two drives and expand the array. I would really, really like to avoid starting again and copying over the data, but worat case, if I have to do so, I do have another QNAP NAS TS 431X with an 8TB disk that the TVS 872xt gets backed up from. (Then I'd have to figure out how to restore the backup to the new volume if this is the case)
Realy appreciate any help/support you may be able to give on this one.

I haven't tried yet but was planning on upgrading the storage in the TS 431X with an additional 8tb into a RAID 0, so hopefully that should be a little more straightforward than adding drives to the RAID 10.

As I said any help is greatly appreciated as always. I have tried to search for a solution without success.
Thanks in advance.
This is something even I didn't know. RAID can not be expanded will need to start from scratch and copy data over.I hope this helps.

Forum Jump:

Users browsing this thread: 1 Guest(s)