Constant disk activity?

I decided to put a NAS in my home and spent several hours watching your videos on models, setup, applications and more. I can honestly say that I don't think there is a better source of information on the internet for anyone interested in NAS solutions. My sincere compliments. Actually, I've had a NAS (QNAP TS-251) running in my office (not set up by me). It's been working great as a simple server solution (using shared folders) for 4 years now and I decided to buy/install one for my home. Last week I got my QNAP TS-251D(4GB version) with two Seagate Iron Wolf 4TB (ST4000VN008) drives and did the RAID-1 setup based on your suggestions. One storage pool with 3 separate volumes, each with a shared folder. Setup was smooth, but since I'm working from home (as is nearly everyone...) I had to pause for about 10 hours before adding any data to the drives. The NAS is located just beneath my desk, and I noticed that the disks were active (noisy) for 30-40 seconds, then a 5-10 second pause, and then back to active. This continued incessantly, for the entire 10 hours of time I was doing other things on my pc without relenting. It didn't make sense, since the drives had finished formatting and there was no data. I had only added a few apps (based on your suggestions, Malware Remover, Security Counselor, QuFirewall). All the other apps were pre-installed. I couldn't understand why the disks were so active. I checked the resource monitor to view the ongoing processes and noticed that there were a large number of ZOMBIE processes running. By large number, I mean it ranged from the lows 10's to the low 100's (about 150 at one point). Made no sense, so I went to my office to verify the situation on my TS-251 (with two 1TB WD Red drives). The resource monitor there showed 1-5 zombie processes going on, but no more. So I opened a support ticket with QNAP and it took them a few days to respond. a) their first suggestion was to change my disks to compatible models (which shocked me since the Seagates I've got are meant for a NAS, and I basically bought them after watching one of your videos). I did check the QNAP compatibility list, and did discover that the specific model number of my Seagates is not listed, but nonetheless, should I spend another 200 quid to fix this problem ??? b) alternatively, they suggested I try downgrading my QTS. When first setting up my TS-251D, I did (as suggested by QNAP and also by you) an immediate firmware update (to version 4.5.2.1630). Funny enough, when checking the link their support sent me, the latest version for my QNAP showed as 4.5.2.1594, and there is no sign of the version that my NAS automatically updated to. Since the idea of buying new drives (for a TEST) didn't appeal to me, I tried downgrading the QTS to see what impact it would have. The downgrade was successful. I don't get any pop-ups telling me that an update is available (which I find strange, since my previous upgrade was a higher number...). Anyway, there is basically no difference in terms of disk activity (constant). The zombie process count is now in the 10-20 range and I haven't seen it go higher (yet). c) they also suggested that I disable any scheduled scanning jobs, but I've only got Malware + AV jobs running at 2-3am respectively. No other jobs. d) their final suggestion of theirs was to remove one drive and see if anything changes. I'd love your advice before trying that. So after a long explanation, I'm hoping that you'll share your thoughts as to what you would do in my place. My office NAP is silent by comparison. Do you truly think that I must either get used to the disks being constantly active (and noisier than the WD’s in my TS-251), or spend another 200 to get drives that are on the TS-251D compatibility list ? Could there be any other causes for the disk activity (a defective device, or defective disk ?)

ST Stevel asked on 13 April 2021, 12:41
0 answers / 381 views / 0 votes

No answers for that question.